EE 231 Fall 2017

Lab 1: Introduction to Verilog HDL and Altera IDE
Introduction

In this lab you will design simple circuits by programming the Field-Programmable Gate Array
(FPGA). At the end of the lab you should be able to understand the process of a Programmable
Logic Device (PLD), and the advantages of such an approach over using discrete components.

1 Prelab
1.1.  Read the material provided in the supplementary section.

1.2 What is a half adder? Explain in terms of input and output signals

1.2.  Using the schematics of the board, if the FPGA sends a logic 1 to one of the LEDs, would
it turn on or off?
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Figure 1: Schematic of Cyclone IV LEDs
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2.1.

2.2

2.3.

2.4.

2.5.

2.6.

2 Lab

Write a gate level Verilog program to implement the half adder circuit shown in Figure 2.

X T ) s
)¢

Figure 2: Half Adder Circuit

Assign your two inputs to the two push buttons and your two outputs to two of the LEDs.
Before you continue, ask the TA to check your assignment.

Perform both functional and timing simulations. The simulations can also be done with
the Logic Analyzer. Print your waveforms. Are the two waveforms the same? Discuss.

Write a Verilog program to implement the same half adder circuit using dataflow
modeling and simulate your circuit again. Note: you don’t have to respecify your
waveforms as you have already saved them in a file.

Program your PLD (be sure to have the correct device selected) to implement your circuit
and verify that it works. Ask the TA to initial your lab book once you have it
working.

Use vectors to describe your inputs and outputs. Send signals to all of the LEDs to have
them off when you send them a logic 0 and turn on when you send them a logic 1, and
similarly, the input to be logic 1 into your circuit when you press the button and zero
otherwise.

3 Supplement Verilog

An introduction to Verilog HDL is discussed in the sections to follow

3.1.

3.2.

In order to write a Verilog HDL description of any circuit you will need to write a
module, which is the fundamental descriptive unit in Verilog. A module is the is a set of
text describing your circuit and is enclosed by the key words module and endmodule.

As the program describes a physical circuit you will need to specify the inputs, the
outputs, the behavior of the circuit, and how the gates are wired. To accomplish this, you
need the keywords input, output, and wire to define the inputs, outputs, and the wiring
between the gates, respectively.
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3.3.

2.1.4.

There are multiple ways to model a circuit:
* Gate level modeling

* Dataflow modeling

* Behavioral modeling

* Or a combination of the above

A simple program modeling the circuit in Figure 2 at the gate level is shown below.
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Figure 2: Simple Circuit

Listing 1: Simple Program in Verilog Modeling a Circuit at the Gate Level

module simple_circuit (output D,E, input A,B,C);

wire wl; // Creating a virtual wire

and Gi(w1,A,B); // Creates AND gate with output wl and inputs A and B
not G2(E,C); // Creates NOT gate output E and input C

or G3(D,w1,E); // Creates OR gate with output D and inputs wl and E

endmodule

Listing 2: Simple Program in Verilog Modeling a Circuit using Data Flow

1 module simple_circuit (output D,E, input A,B,C);
2 wire wl; // Creating a virtual wire
3 assign wl = A & B; // Creates AND gate with output wl and inputs A and B
1 assign E = “C; // Creates NOT gate output E and input C
5 assign D = w1l | E; // Creates OR gate with output D and inputs wi and E
6 endmodule
3.5.  As seen above, the outputs come first in the port list followed by the inputs.
* Single line comments begin with //
*  Multi-line comments are enclosed by /*...*/
* Verilog is case sensitive.
3.6. A simple program modeling a circuit using dataflow is provided in Listing 2.
3.7.  You can use identities describing multiple bits known as vectors. Given an identifier

[7:0]X you can assign value by:

1 assign [7:0] X = 8°b00001111;

Where the 8’b specifies that we are defining an 8 bit binary number and 00001111 is that 8 bit
binary number. You can also assign parts of the number as:
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1 assign [2:0]X = 3°b101;

Which assigns only the last bits 2-0 of X.
4 Supplement: Writing Bad Code

A discussion of poor and incorrect coding practices will follow, with emphasis on how to
correct the mistakes. For purposes of discussion the ill-written code in Listing 3 will be
discussed.

Listing 3: Example of Bad Code

1 module Bad code(AECD,EF);

2 wirel; Define Wire

3 assign wi=C // Assign W1 to input C;

4 asign D = A & B; // Assign D as OR gate with C, A
5 aign E = B | C; /XOR gate

6 assign F = A ~ 1w; // AND gate

7 end modules

4.1  The first line of Bad Code in Listing 3 can either be revised to Listing 4 or Listing 5.

Listing 4: Revision I of Bad Code (Line 1)
1 module BadCode(input A,B,C, output D,E,F); .

Listing 5: Revision II of Bad Code (Line 1)

1 module BadCode(A,B,C,D,E,F);
2 input A,B,C;
3 output D,E,F;

4.2.  The fist line of Bad Code (Listing 4) is necessary when using input and output variables
inside a module. Wire (which are neither inputs, nor outputs) should be defined as seen in
Listing 6.

Listing 6: Definition of Wires

1 wire wi;

4.3.  Whenever a variable (wire) is being given a value, the assign keyword must precede the
variable being set and the associated logic. Revision of Bad Code (Listing 4) lines 3-6 can be
seen in Listing 7.
Listing 7: Proper Usage of Assign Operator
1 assign wl = C; //Assign wl as C;

2 assign D = A & B; // Assign D as AND of A, B
3 assign E=C | B; // Assign E as OR of B, C
4 assign F = A ~ wl; // Assign F as XOR of A, wl

4.4.  The module should be closed with the endmodule keyword. A proper revision of the code
from Listing 3 is as follows in the Listing 8.
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Listing 8: Corrected Implementation of Bad Code
1 assign w1l = C; //Assign wl as C;

2 assign D = A & B; // Assign D as AND of A, B
3 assign E = C | B; // Assign E as OR of B, C

4 assign F = A ~ wl; // Assign F as XOR of A, wi
5 Suplement: Altera Quartus

In order to implement the circuits that you will design on the FPGA, there are a few key steps.
5.1 Starting a new Project
5.1.1. Click “New Project Wizard.”

5.1.2. Set the directory name. Make sure that you create a new folder/directory for each
project and do not copy the directory over.

5.5.3. Set the name of the project. Naming each project after the number of the lab is a good
idea, e.g., Lab_1 HalfAdder.

5.5.4. Click “Yes” to create a directory if it does not exist.
5.5.5. You can add existing files if you already have them, otherwise select “Next.”

5.5.6. Next you need to specify the device that you are using. The device family we are using
is the Cyclone IV E and the device is the EP4ACE22F17C6

5.5.7. Click Next.
5.5.8 Click Finish.

5.2 Writing the Code
5.2.1. Select File > New or Ctrl + N.
5.2.2. Choose Verilog HDL File.
5.2.3. Click Ok.

5.2.4. Select File > Save As. NOTE: The name of the file should be the name of the
Project. Also, the name of the main module needs to be the same name as the file.

5.2.5. Choose Save as type, and select Verilog HDL File.
5.2.6. Put a check mark in the box “Add file” to current project. Unless the file is part of the

project you won’t be able to proceed. If you do not add the file now you can always add it
later by selecting Project > Add/Remove Files to Project.
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5.2.7. Click Save.
Now you are ready to type your program.
5.3  Compiling

5.3.1 To compile your code, you can either go to Processing > Start Compilation, click the
play icon on the toolbar, or use Ctrl + L.

5.3.2. You can click on Processing > Compilation Report to see the results of the compilation.

5.3.3. If there are no errors, then your program’s syntax is correct. This does not mean that
your program will do what you want because you may have some logic errors. Note:
Warnings will not stop your code from compiling but may contain helpful information
for diagnosing logical issues.

5.4  Pin Assignment
Assigning the pins on the FPGA allows the user to interface with the hardware and confirm that
their code works as intended. Some pins have already been internally wired to the LEDs and
push buttons on the board. A list of those pins is provided in Table 1. Be sure the selected device
is the Cyclone IV E: EPACE22F17C6.
5.4.1. Go to Assignments > Pin Planner or Ctrl + Shift + N.
5.4.2. Under Filter select Pins: all.
5.4.3. After successful compilation your input/outputs should already be listed but not
assigned. If you are missing a node, double click <<new node>>; a drop-down menu should
appear to add an input/output. Select the input/output you want to assign.
5.4.4. In the column labeled Location, select the pin you want to assign to that input/output
node. Table 1 shows the locations of the hardwired pins for your evaluation board. For
example: To connect output C to the LED7, you would select Location Pin L3 for Node C.
5.4.5. Repeat Steps 3 and 4 until all inputs/outputs are assigned for your circuit.
5.4.6. The Altera default is that all unused pins should be assigned “As outputs driving
ground.” This is a good choice for pins not connected to anything (it reduces power and
noise), but is not good for pins that may be connected to a clock input — you would then have
both the clock and the Altera chip trying to drive this input. A safer choice is to define all
unused pins “As input tri-stated with weak pull up resistor.”
* Go to Assignments > Device.

* Click on Device and Pin Options.

¢ Select the Unused Pins tab.
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* From the Reserve all unused pins drop-down menu, select “As input tri-stated
with weak pull-up resistor.”

Table 1: Pin Assignments for the LEDs, Push Buttons, DIP-Switches, and Clock inputs

Signal Name CPLD Pin # Description
LEDO PIN_A1S5 LED[0]
LED1 PIN_A13 LED[1]
LED2 PIN_B13 LED[2]
LED3 PIN_Al11 LED([3]
LED4 PIN_D1 LED[4]
LEDS PIN_F3 LED[5]
LEDE PIN_B1 LED[6]
LED7? PIN_L3 LED[7]
KEYO PIN_J15 Push-Button[0]
KEY1 PIN_E1 Push-Button[1]
SW0 PIN_ M1 DIP-Switch[0]
Swi PIN_T8 DIP-Switch[1]
SW2 PIN_B9 DIP-Switch[2]
SW3 PIN_M15 DIP-Switch[3]

CLOCK_50 PIN_R8 50MHz Clock Input

5.5  Simulating the Designed Circuit

Once you have assigned places for the inputs and the outputs as well as values for the inputs, you
can simulate the circuit. The simulation of the circuit can be done in two modes: Functional and
Timing. The Functional Simulation checks that the logic for your function is working correctly.

The Timing Simulation runs the simulation with the delay in the gates included.
In simulating your circuit there are four main steps:
* Create a waveform file.

* Select your inputs and outputs.

* Create a waveform for each input.

* Run the simulation to generate the output for verification with your expected results.

A more detailed explanation of the above steps is described below.

. Select File > New.

. Click on University Program VWE.
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Click Ok.

Save the file using some meaningful name; the name of the lab is a good idea, i.e.
Lab_1 HalfAdder.vwf.

Right-click below Name and select Insert Node or Bus.

Click on Node Finder and click List. This should bring all the outputs and inputs onto
the Nodes Found list.

Use >> to move all the nodes to the Selected Nodes Side.
Click Ok and Ok again.

Set the desired simulation time by selecting Edit > End Time.
Select View > Fit in Window.

Select the inputs and outputs you want to observe by clicking Edit > Insert > Insert
Node or Bus.

Click on Node Finder.

Click on the input/output you want to observe by clicking on the > sign. Repeat this
process for all your inputs/outputs.

The next step is to specify the logic value of each of the inputs you have selected and
duration of that value by right clicking on the input and selecting Value > *your
selected value*

Save the file, e.g. Lab_1 HalfAdder.vwf.

After the waveforms have been defined, we can simulate our circuit. First perform the
functional simulation, and then perform the timing.

o Click Start Functional Simulation or Start Timing Simulation at the top of the
window.

5.6  Programing the FPGA

The final step is to program the FPGA with the circuit you designed. Be sure the correct device
is selected before continuing.

5.6.1 Select Tools > Programmer.

5.6.2. Select JTAG in the Mode box.
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5.6.3. If USB Blaster is not chosen in the box next to Hardware Setup, select by clicking
on the Hardware Setup. Then click on USB-Blaster, the Close.

5.6.4. You should see a file listed with extension .sof, if not add it from Output.

5.6.5. Finally, press Start. The program will download on your board and once it is
finished you can test your circuit in hardware.



